/usr/src/gcc-4.9/debian/patches/pr61841.diff is in gcc-4.9-source 4.9.3-13ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 | # DP: Proposed backport for PR libstdc++/61841
--- a/src/libstdc++-v3/include/std/thread
+++ b/src/libstdc++-v3/include/std/thread
@@ -132,6 +132,9 @@
explicit
thread(_Callable&& __f, _Args&&... __args)
{
+#ifdef GTHR_ACTIVE_PROXY
+ __asm ("" : : "r" (&pthread_create));
+#endif
_M_start_thread(_M_make_routine(std::__bind_simple(
std::forward<_Callable>(__f),
std::forward<_Args>(__args)...)));
|