/usr/src/gcc-4.8/debian/patches/go-testsuite.diff is in gcc-4.8-source 4.8.5-4ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 | # DP: Skip Go testcase on AArch64 which hangs on the buildds.
--- a/src/gcc/testsuite/go.test/go-test.exp
+++ b/src/gcc/testsuite/go.test/go-test.exp
@@ -318,6 +318,14 @@
}
}
+ # Hangs on the buildds
+ if { [istarget "aarch64*-*-*"] } {
+ if { [string match "*go.test/test/chan/select5.go" $test] } {
+ untested $test
+ continue
+ }
+ }
+
if { [file tail $test] == "init1.go" } {
# This tests whether GC runs during init, which for gccgo
# it currently does not.
|