/usr/src/gcc-4.8/debian/patches/ada-driver-check.diff is in gcc-4.8-source 4.8.5-4ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | # DP: Simplify Ada driver check (we always build using the required
# DP: Ada version. Needed for warnings on alpha.
--- a/src/config/acx.m4~ 2007-09-02 19:24:08.865326043 +0200
+++ b/src/config/acx.m4 2007-09-02 19:28:53.719623005 +0200
@@ -380,7 +380,7 @@
# Other compilers, like HP Tru64 UNIX cc, exit successfully when
# given a .adb file, but produce no object file. So we must check
# if an object file was really produced to guard against this.
-errors=`(${CC} $1[]m4_ifval([$1], [ ])-c conftest.adb) 2>&1 || echo failure`
+errors=`(${CC} $1[]m4_ifval([$1], [ ])-c conftest.adb) 2>/dev/null || echo failure`
if test x"$errors" = x && test -f conftest.$ac_objext; then
acx_cv_cc_gcc_supports_ada=yes
fi
--- a/src/configure~ 2007-09-02 16:50:31.206279000 +0200
+++ b/src/configure 2007-09-02 19:28:58.259691491 +0200
@@ -4448,7 +4448,7 @@
# Other compilers, like HP Tru64 UNIX cc, exit successfully when
# given a .adb file, but produce no object file. So we must check
# if an object file was really produced to guard against this.
-errors=`(${CC} -c conftest.adb) 2>&1 || echo failure`
+errors=`(${CC} -c conftest.adb) 2>/dev/null || echo failure`
if test x"$errors" = x && test -f conftest.$ac_objext; then
acx_cv_cc_gcc_supports_ada=yes
fi
|