/usr/src/gcc-4.8/debian/patches/aarch64-call-frame-info.diff is in gcc-4.8-source 4.8.2-19ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 | # DP: Fix call frame information in ffi_closure_SYSV on AArch64.
diff --git a/src/aarch64/sysv.S b/src/aarch64/sysv.S
index 1022454..ecf6371 100644
--- a/src/libffi/src/aarch64/sysv.S
+++ b/src/libffi/src/aarch64/sysv.S
@@ -231,13 +231,13 @@ ffi_closure_SYSV:
cfi_rel_offset (x30, 8)
mov x29, sp
+ cfi_def_cfa_register (x29)
sub sp, sp, #ffi_closure_SYSV_FS
- cfi_adjust_cfa_offset (ffi_closure_SYSV_FS)
stp x21, x22, [x29, #-16]
- cfi_rel_offset (x21, 0)
- cfi_rel_offset (x22, 8)
+ cfi_rel_offset (x21, -16)
+ cfi_rel_offset (x22, -8)
/* Load x21 with &call_context. */
mov x21, sp
@@ -295,7 +295,7 @@ ffi_closure_SYSV:
cfi_restore (x22)
mov sp, x29
- cfi_adjust_cfa_offset (-ffi_closure_SYSV_FS)
+ cfi_def_cfa_register (sp)
ldp x29, x30, [sp], #16
cfi_adjust_cfa_offset (-16)
|