/usr/src/linux-source-3.13.0/debian/rules.d/3-binary-indep.mk is in linux-source-3.13.0 3.13.0-35.62.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 | build-indep:
@echo Debug: $@
# The binary-indep dependency chain is:
#
# install-headers <- install-doc <- install-source <- install-tools <- install-indep <- binary-indep
# install-headers <- binary-headers
#
indep_hdrpkg = $(indep_hdrs_pkg_name)
indep_hdrdir = $(CURDIR)/debian/$(indep_hdrpkg)/usr/src/$(indep_hdrpkg)
install-headers:
@echo Debug: $@
dh_testdir
dh_testroot
dh_prep
ifeq ($(do_flavour_header_package),true)
install -d $(indep_hdrdir)
find . -path './debian' -prune -o -path './$(DEBIAN)' -prune \
-o -path './include/*' -prune \
-o -path './scripts/*' -prune -o -type f \
\( -name 'Makefile*' -o -name 'Kconfig*' -o -name 'Kbuild*' -o \
-name '*.sh' -o -name '*.pl' -o -name '*.lds' \) \
-print | cpio -pd --preserve-modification-time $(indep_hdrdir)
cp -a scripts include $(indep_hdrdir)
(find arch -name include -type d -print | \
xargs -n1 -i: find : -type f) | \
cpio -pd --preserve-modification-time $(indep_hdrdir)
endif
docpkg = $(doc_pkg_name)
docdir = $(CURDIR)/debian/$(docpkg)/usr/share/doc/$(docpkg)
install-doc: install-headers
@echo Debug: $@
ifeq ($(do_doc_package),true)
dh_testdir
dh_testroot
install -d $(docdir)
ifeq ($(do_doc_package_content),true)
# First the html docs. We skip these for autobuilds
if [ -z "$(AUTOBUILD)" ]; then \
install -d $(docdir)/$(doc_pkg_name)-tmp; \
$(kmake) O=$(docdir)/$(doc_pkg_name)-tmp htmldocs; \
mv $(docdir)/$(doc_pkg_name)-tmp/Documentation/DocBook \
$(docdir)/html; \
rm -rf $(docdir)/$(doc_pkg_name)-tmp; \
fi
endif
# Copy the rest
cp -a Documentation/* $(docdir)
rm -rf $(docdir)/DocBook
find $(docdir) -name .gitignore | xargs rm -f
endif
srcpkg = $(src_pkg_name)-source-$(release)
srcdir = $(CURDIR)/debian/$(srcpkg)/usr/src/$(srcpkg)
balldir = $(CURDIR)/debian/$(srcpkg)/usr/src/$(srcpkg)/$(srcpkg)
install-source: install-doc
@echo Debug: $@
ifeq ($(do_source_package),true)
install -d $(srcdir)
ifeq ($(do_source_package_content),true)
find . -path './debian' -prune -o -path './$(DEBIAN)' -prune -o \
-path './.*' -prune -o -print | \
cpio -pd --preserve-modification-time $(balldir)
(cd $(srcdir); tar cf - $(srcpkg)) | bzip2 -9c > \
$(srcdir)/$(srcpkg).tar.bz2
rm -rf $(balldir)
find './debian' './$(DEBIAN)' \
-path './debian/linux-*' -prune -o \
-path './debian/$(src_pkg_name)-*' -prune -o \
-path './debian/build' -prune -o \
-path './debian/files' -prune -o \
-path './debian/stamps' -prune -o \
-path './debian/tmp' -prune -o \
-print | \
cpio -pd --preserve-modification-time $(srcdir)
ln -s $(srcpkg)/$(srcpkg).tar.bz2 $(srcdir)/..
endif
endif
install-tools: toolspkg = $(tools_common_pkg_name)
install-tools: toolsbin = $(CURDIR)/debian/$(toolspkg)/usr/bin
install-tools: toolssbin = $(CURDIR)/debian/$(toolspkg)/usr/sbin
install-tools: toolsman = $(CURDIR)/debian/$(toolspkg)/usr/share/man
install-tools: cloudpkg = $(cloud_common_pkg_name)
install-tools: cloudbin = $(CURDIR)/debian/$(cloudpkg)/usr/bin
install-tools: cloudsbin = $(CURDIR)/debian/$(cloudpkg)/usr/sbin
install-tools: cloudman = $(CURDIR)/debian/$(cloudpkg)/usr/share/man
install-tools: install-source $(stampdir)/stamp-build-perarch
@echo Debug: $@
rm -rf $(builddir)/tools
install -d $(builddir)/tools
for i in *; do ln -s $(CURDIR)/$$i $(builddir)/tools/; done
rm $(builddir)/tools/tools
rsync -a tools/ $(builddir)/tools/tools/
install -d $(toolsbin)
install -d $(toolsman)/man1
install -m755 debian/tools/generic $(toolsbin)/cpupower
install -m644 $(CURDIR)/tools/power/cpupower/man/*.1 $(toolsman)/man1/
install -m755 debian/tools/generic $(toolsbin)/perf
install -m755 debian/tools/generic $(toolsbin)/x86_energy_perf_policy
install -m755 debian/tools/generic $(toolsbin)/turbostat
cd $(builddir)/tools/tools/perf && make man
install -m644 $(builddir)/tools/tools/perf/Documentation/*.1 \
$(toolsman)/man1
install -d $(toolsman)/man8
install -m644 $(CURDIR)/tools/power/x86/x86_energy_perf_policy/*.8 $(toolsman)/man8
install -m644 $(CURDIR)/tools/power/x86/turbostat/*.8 $(toolsman)/man8
install -d $(cloudsbin)
install -m755 debian/tools/generic $(cloudsbin)/hv_kvp_daemon
install -m755 debian/tools/generic $(cloudsbin)/hv_vss_daemon
install -m755 debian/tools/generic $(cloudsbin)/hv_fcopy_daemon
install -m755 debian/cloud-tools/hv_get_dhcp_info $(cloudsbin)
install -m755 debian/cloud-tools/hv_get_dns_info $(cloudsbin)
install -m755 debian/cloud-tools/hv_set_ifconfig $(cloudsbin)
install -d $(cloudman)/man8
install -m644 $(CURDIR)/tools/hv/*.8 $(cloudman)/man8
dh_installinit -p$(cloudpkg) --name hv-kvp-daemon
dh_installinit -p$(cloudpkg) --name hv-vss-daemon
dh_installinit -p$(cloudpkg) --name hv-fcopy-daemon
install-indep: install-tools
@echo Debug: $@
# This is just to make it easy to call manually. Normally done in
# binary-indep target during builds.
binary-headers: install-headers
@echo Debug: $@
dh_installchangelogs -p$(indep_hdrpkg)
dh_installdocs -p$(indep_hdrpkg)
dh_compress -p$(indep_hdrpkg)
dh_fixperms -p$(indep_hdrpkg)
dh_installdeb -p$(indep_hdrpkg)
$(lockme) dh_gencontrol -p$(indep_hdrpkg)
dh_md5sums -p$(indep_hdrpkg)
dh_builddeb -p$(indep_hdrpkg)
binary-indep: install-indep
@echo Debug: $@
dh_installchangelogs -i
dh_installdocs -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
$(lockme) dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
|