/usr/src/linux-source-3.13.0/debian/tests/ubuntu-regression-suite is in linux-source-3.13.0 3.13.0-103.150.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 | #!/bin/sh
set -e
sver=`dpkg-parsechangelog -SVersion`
read x rver x </proc/version_signature
flavour=${rver#*-*-}
rver=${rver%-$flavour}
echo "Source Package Version: $sver"
echo "Running Kernel Version: $rver"
if [ "$sver" != "$rver" ]; then
echo "ERROR: running version does not match source package" 1>&2
exit 1
fi
git clone git://kernel.ubuntu.com/ubuntu/kernel-testing
kernel-testing/run-dep8-tests
|