/usr/lib/python2.7/dist-packages/debian/copyright.py is in python-debian 0.1.32.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 | # vim: fileencoding=utf-8
#
# Copyright (C) 2014 Google, Inc.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation, either version 2
# of the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
"""Utilities for parsing and creating machine-readable debian/copyright files.
The specification for the format (also known as DEP5) is available here:
https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Start from the Coyright docstring for usage information.
"""
from __future__ import unicode_literals
import collections
import itertools
import io
import re
import warnings
from debian import deb822
_CURRENT_FORMAT = (
'http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/')
_KNOWN_FORMATS = frozenset([
_CURRENT_FORMAT,
# TODO(jsw): Transparently rewrite https:// as http://, at least for this?
'https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/',
])
class Error(Exception):
"""Base class for exceptions in this module."""
class NotMachineReadableError(Error):
"""Raised when the input is not a machine-readable debian/copyright file."""
class Copyright(object):
"""Represents a debian/copyright file.
A Copyright object contains a Header paragraph and a list of additional
Files or License paragraphs. It provides methods to iterate over those
paragraphs, in addition to adding new ones. It also provides a mechanism
for finding the Files paragraph (if any) that matches a particular
filename.
Typical usage:
with io.open('debian/copyright', 'rt', encoding='utf-8') as f:
c = copyright.Copyright(f)
header = c.header
# Header exposes standard fields, e.g.
print('Upstream name: ', header.upstream_name)
lic = header.license
if lic:
print('Overall license: ', lic.synopsis)
# You can also retrive and set custom fields.
header['My-Special-Field'] = 'Very special'
# Find the license for a given file.
paragraph = c.find_files_paragraph('debian/rules')
if paragraph:
print('License for debian/rules: ', paragraph.license)
# Dump the result, including changes, to another file.
with io.open('debian/copyright.new', 'wt', encoding='utf-8') as f:
c.dump(f=f)
It is possible to build up a Copyright from scratch, by modifying the
header and using add_files_paragraph and add_license_paragraph. See the
associated method docstrings.
"""
def __init__(self, sequence=None, encoding='utf-8'):
"""Initializer.
:param sequence: Sequence of lines, e.g. a list of strings or a
file-like object. If not specified, a blank Copyright object is
initialized.
:param encoding: Encoding to use, in case input is raw byte strings.
It is recommended to use unicode objects everywhere instead, e.g.
by opening files in text mode.
Raises:
NotMachineReadableError if 'sequence' does not contain a
machine-readable debian/copyright file.
"""
super(Copyright, self).__init__()
self.__paragraphs = []
if sequence is not None:
paragraphs = list(deb822.Deb822.iter_paragraphs(
sequence=sequence, encoding=encoding))
if not paragraphs:
raise NotMachineReadableError('no paragraphs in input')
self.__header = Header(paragraphs[0])
for i in range(1, len(paragraphs)):
p = paragraphs[i]
if 'Files' in p:
p = FilesParagraph(p)
elif 'License' in p:
p = LicenseParagraph(p)
else:
warnings.warn('Non-header paragraph has neither "Files"'
' nor "License" fields')
self.__paragraphs.append(p)
else:
self.__header = Header()
@property
def header(self):
"""The file header paragraph."""
return self.__header
@header.setter
def header(self, hdr):
if not isinstance(hdr, Header):
raise TypeError('value must be a Header object')
self.__header = hdr
def all_paragraphs(self):
"""Returns an iterator over all paragraphs (header, Files, License).
The header (returned first) will be returned as a Header object; file
paragraphs as FilesParagraph objects; license paragraphs as
LicenseParagraph objects.
"""
return itertools.chain([self.header], (p for p in self.__paragraphs))
def __iter__(self):
"""Iterate over all paragraphs
see all_paragraphs() for more information
"""
return self.all_paragraphs()
def all_files_paragraphs(self):
"""Returns an iterator over the contained FilesParagraph objects."""
return (p for p in self.__paragraphs if isinstance(p, FilesParagraph))
def find_files_paragraph(self, filename):
"""Returns the FilesParagraph for the given filename.
In accordance with the spec, this method returns the last FilesParagraph
that matches the filename. If no paragraphs matched, returns None.
"""
result = None
for p in self.all_files_paragraphs():
if p.matches(filename):
result = p
return result
def add_files_paragraph(self, paragraph):
"""Adds a FilesParagraph to this object.
The paragraph is inserted directly after the last FilesParagraph (which
might be before a standalone LicenseParagraph).
"""
if not isinstance(paragraph, FilesParagraph):
raise TypeError('paragraph must be a FilesParagraph instance')
last_i = -1
for i, p in enumerate(self.__paragraphs):
if isinstance(p, FilesParagraph):
last_i = i
self.__paragraphs.insert(last_i + 1, paragraph)
def all_license_paragraphs(self):
"""Returns an iterator over standalone LicenseParagraph objects."""
return (p for p in self.__paragraphs if isinstance(p, LicenseParagraph))
def add_license_paragraph(self, paragraph):
"""Adds a LicenceParagraph to this object.
The paragraph is inserted after any other paragraphs.
"""
if not isinstance(paragraph, LicenseParagraph):
raise TypeError('paragraph must be a LicenseParagraph instance')
self.__paragraphs.append(paragraph)
def dump(self, f=None):
"""Dumps the contents of the copyright file.
If f is None, returns a unicode object. Otherwise, writes the contents
to f, which must be a file-like object that is opened in text mode
(i.e. that accepts unicode objects directly). It is thus up to the
caller to arrange for the file to do any appropriate encoding.
"""
return_string = False
if f is None:
return_string = True
f = io.StringIO()
self.header.dump(f, text_mode=True)
for p in self.__paragraphs:
f.write('\n')
p.dump(f, text_mode=True)
if return_string:
return f.getvalue()
def _single_line(s):
"""Returns s if it is a single line; otherwise raises ValueError."""
if '\n' in s:
raise ValueError('must be single line')
return s
class _LineBased(object):
"""Namespace for conversion methods for line-based lists as tuples."""
# TODO(jsw): Expose this somewhere else? It may have more general utility.
@staticmethod
def from_str(s):
"""Returns the lines in 's', with whitespace stripped, as a tuple."""
return tuple(v for v in
(line.strip() for line in (s or '').strip().splitlines())
if v)
@staticmethod
def to_str(seq):
"""Returns the sequence as a string with each element on its own line.
If 'seq' has one element, the result will be on a single line.
Otherwise, the first line will be blank.
"""
l = list(seq)
if not l:
return None
def process_and_validate(s):
s = s.strip()
if not s:
raise ValueError('values must not be empty')
if '\n' in s:
raise ValueError('values must not contain newlines')
return s
if len(l) == 1:
return process_and_validate(l[0])
tmp = ['']
for s in l:
tmp.append(' ' + process_and_validate(s))
return '\n'.join(tmp)
class _SpaceSeparated(object):
"""Namespace for conversion methods for space-separated lists as tuples."""
# TODO(jsw): Expose this somewhere else? It may have more general utility.
_has_space = re.compile(r'\s')
@staticmethod
def from_str(s):
"""Returns the values in s as a tuple (empty if only whitespace)."""
return tuple(v for v in (s or '').split() if v)
@classmethod
def to_str(cls, seq):
"""Returns the sequence as a space-separated string (None if empty)."""
l = list(seq)
if not l:
return None
tmp = []
for s in l:
if cls._has_space.search(s):
raise ValueError('values must not contain whitespace')
s = s.strip()
if not s:
raise ValueError('values must not be empty')
tmp.append(s)
return ' '.join(tmp)
# TODO(jsw): Move multiline formatting/parsing elsewhere?
def format_multiline(s):
"""Formats multiline text for insertion in a Deb822 field.
Each line except for the first one is prefixed with a single space. Lines
that are blank or only whitespace are replaced with ' .'
"""
if s is None:
return None
return format_multiline_lines(s.splitlines())
def format_multiline_lines(lines):
"""Same as format_multline, but taking input pre-split into lines."""
out_lines = []
for i, line in enumerate(lines):
if i != 0:
if not line.strip():
line = '.'
line = ' ' + line
out_lines.append(line)
return '\n'.join(out_lines)
def parse_multiline(s):
"""Inverse of format_multiline.
Technically it can't be a perfect inverse, since format_multline must
replace all-whitespace lines with ' .'. Specifically, this function:
- Does nothing to the first line
- Removes first character (which must be ' ') from each proceeding line.
- Replaces any line that is '.' with an empty line.
"""
if s is None:
return None
return '\n'.join(parse_multiline_as_lines(s))
def parse_multiline_as_lines(s):
"""Same as parse_multiline, but returns a list of lines.
(This is the inverse of format_multiline_lines.)
"""
lines = s.splitlines()
for i, line in enumerate(lines):
if i == 0:
continue
if line.startswith(' '):
line = line[1:]
else:
raise ValueError('continued line must begin with " "')
if line == '.':
line = ''
lines[i] = line
return lines
class License(collections.namedtuple('License', 'synopsis text')):
"""Represents the contents of a License field. Immutable."""
def __new__(cls, synopsis, text=''):
"""Creates a new License object.
:param synopsis: The short name of the license, or an expression giving
alternatives. (The first line of a License field.)
:param text: The full text of the license, if any (may be None). The
lines should not be mangled for "deb822"-style wrapping - i.e. they
should not have whitespace prefixes or single '.' for empty lines.
"""
return super(License, cls).__new__(
cls, synopsis=_single_line(synopsis), text=(text or ''))
@classmethod
def from_str(cls, s):
if s is None:
return None
lines = parse_multiline_as_lines(s)
if not lines:
return cls('')
return cls(lines[0], text='\n'.join(itertools.islice(lines, 1, None)))
def to_str(self):
return format_multiline_lines([self.synopsis] + self.text.splitlines())
# TODO(jsw): Parse the synopsis?
# TODO(jsw): Provide methods to look up license text for known licenses?
def globs_to_re(globs):
r"""Returns an re object for the given globs.
Only * and ? wildcards are supported. Literal * and ? may be matched via
\* and \?, respectively. A literal backslash is matched \\. Any other
character after a backslash is forbidden.
Empty globs match nothing.
Raises ValueError if any of the globs is illegal.
"""
buf = io.StringIO()
for i, glob in enumerate(globs):
if i != 0:
buf.write('|')
i = 0
n = len(glob)
while i < n:
c = glob[i]
i += 1
if c == '*':
buf.write('.*')
elif c == '?':
buf.write('.')
elif c == '\\':
if i < n:
c = glob[i]
i += 1
else:
raise ValueError('single backslash not allowed at end')
if c in r'\?*':
buf.write(re.escape(c))
else:
raise ValueError(r'invalid escape sequence: \%s' % c)
else:
buf.write(re.escape(c))
# Patterns must be anchored at the end of the string. (We use \Z instead
# of $ so that this works correctly for filenames including \n.)
buf.write(r'\Z')
return re.compile(buf.getvalue(), re.MULTILINE | re.DOTALL)
class FilesParagraph(deb822.RestrictedWrapper):
"""Represents a Files paragraph of a debian/copyright file.
This kind of paragraph is used to specify the copyright and license for a
particular set of files in the package.
"""
def __init__(self, data, _internal_validate=True):
super(FilesParagraph, self).__init__(data)
if _internal_validate:
if 'Files' not in data:
raise ValueError('"Files" field required')
# For the other "required" fields, we just warn for now. Perhaps
# these should be upgraded to exceptions (potentially protected by
# a "strict" param).
if 'Copyright' not in data:
warnings.warn('Files paragraph missing Copyright field')
if 'License' not in data:
warnings.warn('Files paragraph missing License field')
if not self.files:
warnings.warn('Files paragraph has empty Files field')
self.__cached_files_pat = (None, None)
@classmethod
def create(cls, files, copyright, license):
"""Create a new FilesParagraph from its required parts.
:param files: The list of file globs.
:param copyright: The copyright for the files (free-form text).
:param license: The Licence for the files.
"""
p = cls(deb822.Deb822(), _internal_validate=False)
p.files = files
p.copyright = copyright
p.license = license
return p
def files_pattern(self):
"""Returns a regular expression equivalent to the Files globs.
Caches the result until files is set to a different value.
Raises ValueError if any of the globs are invalid.
"""
files_str = self['files']
if self.__cached_files_pat[0] != files_str:
self.__cached_files_pat = (files_str, globs_to_re(self.files))
return self.__cached_files_pat[1]
def matches(self, filename):
"""Returns True iff filename is matched by a glob in Files."""
pat = self.files_pattern()
return pat.match(filename) is not None
files = deb822.RestrictedField(
'Files', from_str=_SpaceSeparated.from_str,
to_str=_SpaceSeparated.to_str, allow_none=False)
copyright = deb822.RestrictedField('Copyright', allow_none=False)
license = deb822.RestrictedField(
'License', from_str=License.from_str, to_str=License.to_str,
allow_none=False)
comment = deb822.RestrictedField('Comment')
class LicenseParagraph(deb822.RestrictedWrapper):
"""Represents a standalone license paragraph of a debian/copyright file.
Minimally, this kind of paragraph requires a 'License' field and has no
'Files' field. It is used to give a short name to a license text, which
can be referred to from the header or files paragraphs.
"""
def __init__(self, data, _internal_validate=True):
super(LicenseParagraph, self).__init__(data)
if _internal_validate:
if 'License' not in data:
raise ValueError('"License" field required')
if 'Files' in data:
raise ValueError('input appears to be a Files paragraph')
@classmethod
def create(cls, license):
"""Returns a LicenseParagraph with the given license."""
if not isinstance(license, License):
raise TypeError('license must be a License instance')
paragraph = cls(deb822.Deb822(), _internal_validate=False)
paragraph.license = license
return paragraph
# TODO(jsw): Validate that the synopsis of the license is a short name or
# short name with exceptions (not an alternatives expression). This
# requires help from the License class.
license = deb822.RestrictedField(
'License', from_str=License.from_str, to_str=License.to_str,
allow_none=False)
comment = deb822.RestrictedField('Comment')
# Hide 'Files'.
__files = deb822.RestrictedField('Files')
class Header(deb822.RestrictedWrapper):
"""Represents the header paragraph of a debian/copyright file.
Property values are all immutable, such that in order to modify them you
must explicitly set them (rather than modifying a returned reference).
"""
def __init__(self, data=None):
"""Initializer.
:param parsed: A deb822.Deb822 object for underlying data. If None, a
new one will be created.
"""
if data is None:
data = deb822.Deb822()
data['Format'] = _CURRENT_FORMAT
if 'Format-Specification' in data:
warnings.warn('use of deprecated "Format-Specification" field;'
' rewriting as "Format"')
data['Format'] = data['Format-Specification']
del data['Format-Specification']
super(Header, self).__init__(data)
fmt = self.format
if fmt is None:
raise NotMachineReadableError(
'input is not a machine-readable debian/copyright')
if fmt not in _KNOWN_FORMATS:
warnings.warn('format not known: %r' % fmt)
def known_format(self):
"""Returns True iff the format is known."""
return self.format in _KNOWN_FORMATS
def current_format(self):
"""Returns True iff the format is the current format."""
return self.format == _CURRENT_FORMAT
format = deb822.RestrictedField(
'Format', to_str=_single_line, allow_none=False)
upstream_name = deb822.RestrictedField(
'Upstream-Name', to_str=_single_line)
upstream_contact = deb822.RestrictedField(
'Upstream-Contact', from_str=_LineBased.from_str,
to_str=_LineBased.to_str)
source = deb822.RestrictedField('Source')
disclaimer = deb822.RestrictedField('Disclaimer')
comment = deb822.RestrictedField('Comment')
license = deb822.RestrictedField(
'License', from_str=License.from_str, to_str=License.to_str)
copyright = deb822.RestrictedField('Copyright')
|