/usr/share/obs/api/files/wizardtemplate.spec is in obs-api 2.7.4-2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 | Name: <%= @name %>
# List of additional build dependencies
<% if @packtype == "python"
%>BuildRequires: python-devel<%
else
%>#BuildRequires: gcc-c++ libxml2-devel<%
end %>
Version: <%= @version %>
Release: 1
License: <%= @license %>
Source: <%= @tarball %>
Group: <%= @group %>
Summary: <%= @summary %>
<% if @packtype == "perl"
%>Requires: perl = %{perl_version}<%
elsif @packtype == "python"
%>%py_requires<%
end %>
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
<%= @description.gsub(/([^\n]{1,70})([ \t]+|\n|$)/, "\\1\n") %>
%prep
<%=
# FIXME: escape special characters in name and version
if @tarball =~ /^#{@name}-#{@version}\.tar\.(gz|bz2)$/
"%setup -q"
elsif @tarball =~ /^(.*)-#{@version}\.tar\.(gz|bz2)$/
"%setup -q -n #{$1}-%version"
elsif @tarball =~ /^(.*)\.tar\.(gz|bz2)$/
"%setup -q -n #{$1}"
else # give up
"%setup -q"
end
%>
%build
<% if @packtype == "generic" %>
# Assume that the package is built by plain 'make' if there's no ./configure.
# This test is there only because the wizard doesn't know much about the
# package, feel free to clean it up
if test -x ./configure; then
%configure
fi
make
<% elsif @packtype == "perl" %>
perl Makefile.PL
make
<% elsif @packtype == "python" %>
python setup.py build
<% else raise RuntimeError.new("WizardError: unknown packtype #{@packtype}") %>
<% end %>
%install
<% if @packtype == "generic" %>
make DESTDIR=%buildroot install
<% elsif @packtype == "perl" %>
make DESTDIR=%buildroot install_vendor
%perl_process_packlist
<% elsif @packtype == "python" %>
python setup.py install --prefix=%_prefix --root=%buildroot --record-rpm=filelist
<% else raise RuntimeError.new("WizardError: unknown packtype #{@packtype}") %>
<% end %>
<% if @packtype != "python" %>
# Write a proper %%files section and remove these two commands and
# the '-f filelist' option to %%files
echo '%%defattr(-,root,root)' >filelist
find %buildroot -type f -printf '/%%P*\n' >>filelist
<% end %>
%clean
rm -rf %buildroot
%files -f filelist
%defattr(-,root,root)
<%
# '%files -f' seems to be standard practice in python packages, so only display
# the comment in non-python cases
if @packtype != "python" %>
# This is a place for a proper filelist:
# /usr/bin/<%= @name %>
# You can also use shell wildcards:
# /usr/share/<%= @name %>/*
# This installs documentation files from the top build directory
# into /usr/share/doc/...
# %doc README COPYING
# The advantage of using a real filelist instead of the '-f filelist' trick is
# that rpmbuild will detect if the install section forgets to install
# something that is listed here
<% end %>
%changelog
* <%= Date.today.strftime("%a %b %d %Y") %> <%= @email %>
- packaged <%= @name %> version <%= @version %> using the buildservice spec file wizard
|