/usr/src/gcc-6/debian/patches/pr64735-headers.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 | --- a/src/libstdc++-v3/include/std/future
+++ b/src/libstdc++-v3/include/std/future
@@ -183,7 +183,7 @@
async(_Fn&& __fn, _Args&&... __args);
#if defined(_GLIBCXX_HAS_GTHREADS) && defined(_GLIBCXX_USE_C99_STDINT_TR1) \
- && (ATOMIC_INT_LOCK_FREE > 1)
+ && ((ATOMIC_INT_LOCK_FREE > 1) || (defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)))
/// Base class and enclosing scope.
struct __future_base
--- a/src/libstdc++-v3/libsupc++/exception_ptr.h
+++ b/src/libstdc++-v3/libsupc++/exception_ptr.h
@@ -36,9 +36,11 @@
#include <bits/c++config.h>
#include <bits/exception_defines.h>
+#if !(defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP))
#if ATOMIC_INT_LOCK_FREE < 2
# error This platform does not support exception propagation.
#endif
+#endif
extern "C++" {
--- a/src/libstdc++-v3/libsupc++/nested_exception.h
+++ b/src/libstdc++-v3/libsupc++/nested_exception.h
@@ -39,9 +39,11 @@
#include <bits/c++config.h>
#include <bits/move.h>
+#if !(defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP))
#if ATOMIC_INT_LOCK_FREE < 2
# error This platform does not support exception propagation.
#endif
+#endif
extern "C++" {
--- a/src/libstdc++-v3/libsupc++/exception
+++ b/src/libstdc++-v3/libsupc++/exception
@@ -35,7 +35,9 @@
#pragma GCC visibility push(default)
#include <bits/c++config.h>
+#if !(defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP))
#include <bits/atomic_lockfree_defines.h>
+#endif
extern "C++" {
@@ -166,7 +168,7 @@
#pragma GCC visibility pop
-#if (__cplusplus >= 201103L) && (ATOMIC_INT_LOCK_FREE > 1)
+#if (__cplusplus >= 201103L) && ((ATOMIC_INT_LOCK_FREE > 1) || (defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)))
#include <bits/exception_ptr.h>
#include <bits/nested_exception.h>
#endif
|