/usr/src/gcc-6/debian/patches/libgo-add-getrandom-mips-sparc.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 | # DP: Backport r240457 from trunk
internal/syscall/unix: add getrandom syscall for MIPS and SPARC
Reviewed-on: https://go-review.googlesource.com/29678
Index: b/src/libgo/go/internal/syscall/unix/getrandom_linux_mipso32.go
===================================================================
--- a/src/libgo/go/internal/syscall/unix/getrandom_linux_mipso32.go (nonexistent)
+++ b/src/libgo/go/internal/syscall/unix/getrandom_linux_mipso32.go (revision 240457)
@@ -0,0 +1,11 @@
+// Copyright 2016 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+// +build mipso32
+
+package unix
+
+// Linux getrandom system call number.
+// See GetRandom in getrandom_linux.go.
+const randomTrap uintptr = 4353
Index: b/src/libgo/go/internal/syscall/unix/getrandom_linux_sparc.go
===================================================================
--- a/src/libgo/go/internal/syscall/unix/getrandom_linux_sparc.go (nonexistent)
+++ b/src/libgo/go/internal/syscall/unix/getrandom_linux_sparc.go (revision 240457)
@@ -0,0 +1,11 @@
+// Copyright 2016 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+// +build sparc sparc64
+
+package unix
+
+// Linux getrandom system call number.
+// See GetRandom in getrandom_linux.go.
+const randomTrap uintptr = 347
Index: b/src/libgo/go/internal/syscall/unix/getrandom_linux_mips64x.go
===================================================================
--- a/src/libgo/go/internal/syscall/unix/getrandom_linux_mips64x.go (revision 240456)
+++ b/src/libgo/go/internal/syscall/unix/getrandom_linux_mips64x.go (revision 240457)
@@ -2,7 +2,7 @@
// Use of this source code is governed by a BSD-style
// license that can be found in the LICENSE file.
-// +build mips64 mips64le
+// +build mips64 mips64le mipsn64 mipso64
package unix
Index: b/src/libgo/go/internal/syscall/unix/getrandom_linux_mipsn32.go
===================================================================
--- a/src/libgo/go/internal/syscall/unix/getrandom_linux_mipsn32.go (nonexistent)
+++ b/src/libgo/go/internal/syscall/unix/getrandom_linux_mipsn32.go (revision 240457)
@@ -0,0 +1,11 @@
+// Copyright 2016 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+// +build mipsn32
+
+package unix
+
+// Linux getrandom system call number.
+// See GetRandom in getrandom_linux.go.
+const randomTrap uintptr = 6317
|