/usr/src/gcc-6/debian/patches/libcc1-compiler-name.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 | # DP: Don't add the configured prefix to libcc1's compiler name.
--- a/src/libcc1/Makefile.am
+++ b/src/libcc1/Makefile.am
@@ -49,7 +49,7 @@
# Put this in a header so we don't run sed for each compilation. This
# is also simpler to debug as one can easily see the constant.
compiler-name.h: Makefile
- echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@
+ echo "#define COMPILER_NAME \"`echo gcc-6`\"" > $@
shared_source = callbacks.cc callbacks.hh connection.cc connection.hh \
--- a/src/libcc1/Makefile.in
+++ b/src/libcc1/Makefile.in
@@ -674,7 +674,7 @@
# Put this in a header so we don't run sed for each compilation. This
# is also simpler to debug as one can easily see the constant.
compiler-name.h: Makefile
- echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@
+ echo "#define COMPILER_NAME \"`echo gcc-6`\"" > $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
|