/usr/src/binutils/debian/tests/shlib-build is in binutils-source 2.30-15ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 | #!/bin/sh
# autopkgtest check: Build and link against a simple shared library, to test
# basic binutils compile-time and run-time linking functionality.
#
# (C) 2012 Canonical Ltd.
# Author: Martin Pitt <martin.pitt@ubuntu.com>
set -e
WORKDIR=$(mktemp -d)
trap "rm -rf $WORKDIR" 0 INT QUIT ABRT PIPE TERM
cd $WORKDIR
cat <<EOF > testlib.c
int ultimate_answer()
{
return 42;
}
EOF
gcc -Wall -Werror -shared -o libultimate.so testlib.c
echo "library build: OK"
# should export the symbol
nm -D libultimate.so | grep -q 'T ultimate_answer'
# link it against a program
cat <<EOF > testprog.c
#include <assert.h>
int ultimate_answer();
int main()
{
assert (ultimate_answer() == 42);
return 0;
}
EOF
gcc -Wall -Werror -L . -o testprog testprog.c -lultimate
echo "program build: OK"
[ -x testprog ]
LD_LIBRARY_PATH=. ./testprog
echo "run: OK"
|