/usr/src/binutils/debian/tests/libc-link is in binutils-source 2.30-15ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 | #!/bin/sh
# autopkgtest check: Build and run a simple program against libc, to verify
# basic binutils compile-time and run-time linking functionality.
#
# (C) 2012 Canonical Ltd.
# Author: Martin Pitt <martin.pitt@ubuntu.com>
set -e
WORKDIR=$(mktemp -d)
trap "rm -rf $WORKDIR" 0 INT QUIT ABRT PIPE TERM
cd $WORKDIR
cat <<EOF > libctest.c
#include <string.h>
#include <assert.h>
int main()
{
assert (1 > 0);
assert (strcmp ("hello", "hello") == 0);
return 0;
}
EOF
gcc -o libctest libctest.c
echo "build: OK"
[ -x libctest ]
./libctest
echo "run: OK"
|